Motion - Bug Report 2009x 01x 25x 183936
You are here: Foswiki>Motion Web>BugReports>BugReport2009x01x25x183936 (10 Aug 2009, AngelCarpintero)Edit Attach

BUG: ffmpeg header files not found my config script

In my package for ffmpeg header files (ffmpeg-devel-0.4.9-0.48.20080908.fc9.x86_64), they seem to have unusual locations:

/usr/include/ffmpeg/libavcodec /usr/include/ffmpeg/libavcodec/avcodec.h /usr/include/ffmpeg/libavcodec/opt.h /usr/include/ffmpeg/libavdevice /usr/include/ffmpeg/libavdevice/avdevice.h /usr/include/ffmpeg/libavfilter /usr/include/ffmpeg/libavfilter/avfilter.h /usr/include/ffmpeg/libavformat /usr/include/ffmpeg/libavformat/avformat.h /usr/include/ffmpeg/libavformat/avio.h /usr/include/ffmpeg/libavformat/rtsp.h /usr/include/ffmpeg/libavformat/rtspcodes.h /usr/include/ffmpeg/libavutil /usr/include/ffmpeg/libavutil/adler32.h /usr/include/ffmpeg/libavutil/avstring.h /usr/include/ffmpeg/libavutil/avutil.h /usr/include/ffmpeg/libavutil/base64.h /usr/include/ffmpeg/libavutil/common.h /usr/include/ffmpeg/libavutil/crc.h /usr/include/ffmpeg/libavutil/fifo.h /usr/include/ffmpeg/libavutil/intfloat_readwrite.h /usr/include/ffmpeg/libavutil/log.h /usr/include/ffmpeg/libavutil/lzo.h /usr/include/ffmpeg/libavutil/mathematics.h /usr/include/ffmpeg/libavutil/md5.h /usr/include/ffmpeg/libavutil/mem.h /usr/include/ffmpeg/libavutil/random.h /usr/include/ffmpeg/libavutil/rational.h /usr/include/ffmpeg/libavutil/sha1.h /usr/include/ffmpeg/libpostproc /usr/include/ffmpeg/libpostproc/postprocess.h /usr/include/ffmpeg/libswscale /usr/include/ffmpeg/libswscale/rgb2rgb.h /usr/include/ffmpeg/libswscale/swscale.h

I linked all the headers down to the ffmpeg base directory to make the motion-3.2.11 tar-ball configure and compile with ffmpeg.

Perhaps this still needs to be adjusted.

Cheers,

Axel

./configure --with-ffmpeg=yes

Environment

Motion version: 3.2.11
ffmpeg version: 0.4.9
Shared libraries: ffmpeg
Server OS: fc9

-- AxelRossberg - 25 Jan 2009

Follow up

Take a look to release notes page :

http://www.lavrsen.dk/twiki/bin/view/Motion/ReleaseNoteMotion3x2x11

There're 2 patches related to ffmpeg detection , i'm pretty sure that will fix your issue

Also this issue was discussed in mailing list for Fedora core 10.

-- AngelCarpintero - 31 Jan 2009

Fix record

No feedback and patches already included in release notes page.

-- AngelCarpintero - 17 Jul 2009
Topic revision: r4 - 10 Aug 2009, AngelCarpintero
Copyright © 1999-2021 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.