pan & tilt problem

Question

I have a Logitech Sphere webcam.

I have installed motion (3.2.6-2) from .deb package, pwc (10.0.10-1) and libxmrrpc-c3 (0.9.10-4).

Webcam works, but pan & tilt doesn't.

From http://localhost:8080 I can set pan & tilt.

From my webpage (http://webkamera.......org/livecam.htm), it doesn't work. Kenneth removed the URL as it is on the public spam list -- KennethLavrsen - 05 Nov 2006

Motion.conf details:

... track_type 3

control_localhost off

track_auto off ....

OS: Debian (testing) Kernel release: 2.6.17.070719nvidia (custom)


Environment

Motion version: 3.2.6-2
ffmpeg version: 3:20060305-0.1
Libraries: libxmrrpc-c3 (0.9.10-4), ffmpeg
Server OS: Debian (testing), kernel release 2.6.17.

-- IstvanVegh - 25 Jul 2006

Answer

Glad you found your way into the Motion TWiki smile

How is the link from your homepage to the control port of TWiki?

-- KennethLavrsen - 25 Jul 2006

Update to motion 3.2.7 and try to reproduce the problem. Reopen the support question if problem remains.

-- AngelCarpintero - 05 Nov 2006

I think his problem was that he had not understood that the server had to fetch the URL that did the pan/tilt. The client browser could not fetch the URL even if it was seen on the webpage. Unless he had made the control interface accessible through his firewall and THAT would have been equal to giving people a command prompt with no password. The Motion control interface must never be exposed to the world. You can execute any command through it with the on_xxxx options.

But since the reporter never came back we will never know.

-- KennethLavrsen - 05 Nov 2006
Topic revision: 05 Nov 2006, KennethLavrsen
 
Motion - Support Question 2006x 07x 25x 200826
Copyright 1999-2014 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.