Motion - Release Bug Fixes

Released Bug Fixes

Bugs that have been fixed and the fix is in a released version of Motion.

Headline Submitted By Age Last Change
netcam green screen DennisOpanasenko 5118 12 Feb 2013 - 17:30
ArnoTixe
Segfault when using with tw68 RomanGaufman 4506 03 Jun 2012 - 01:54
AngelCarpintero
Genius Cam doesn't work with karmic and motion 3.2.11.1. WikiGuest 4593 03 Jun 2012 - 01:53
AngelCarpintero
Motion beyond 20100121 no longer builds without ffmpeg RichardB 4530 03 Jun 2012 - 01:53
AngelCarpintero
camera input parameter is valid from 0 to 15 except 8 LaszloVarga 4172 03 Jun 2012 - 01:52
AngelCarpintero
Cannot compile with latest ffmpeg (SVN-r25563) BertrandAchard 4261 03 Jun 2012 - 01:52
AngelCarpintero
linux/videodev.h: No such file or directory WikiGuest 3791 03 Jun 2012 - 01:52
AngelCarpintero
Seg Fault in fresh REV504 compile JimHoward 4463 03 Jun 2012 - 01:51
AngelCarpintero
Name space clash with libjpeg8 KennethLavrsen 4537 03 Jun 2012 - 01:50
AngelCarpintero
Motion won't compile with ljbjpeg >=8 McGibbon 4487 03 Jun 2012 - 01:49
AngelCarpintero
No mysql_close RichardA 4233 03 Jun 2012 - 01:48
AngelCarpintero
ffmpeg writes FLV files even when FFV1 is selected. TobyCorkindale 4456 03 Jun 2012 - 01:44
AngelCarpintero
'VIDEO_PALETTE_YUV420P’ undeclared is coming back WikiGuest 3785 02 Jun 2012 - 04:49
AngelCarpintero
SEGV on reload or quit for vloopback (maybe other v4l1 devices too) WikiGuest 4756 17 Apr 2010 - 18:11
AngelCarpintero
Possible buffer overflow StevenM 4861 10 Aug 2009 - 00:44
AngelCarpintero
UVCVideo not working in Ubuntu 8.10 kernel 2.6.27 TWikiGuest 4895 10 Aug 2009 - 00:44
AngelCarpintero
error in make.../usr/include/ffmpeg/libavformat/avformat.h:714: error: expected declaration specifiers or '...' before 'AVPacket' MeuNome 4803 10 Aug 2009 - 00:43
AngelCarpintero
__USE_GNU redefined PeterHolik 4755 10 Aug 2009 - 00:43
AngelCarpintero
configure script can't find ffmpeg include files AxelRossberg 4898 10 Aug 2009 - 00:43
AngelCarpintero
Ubuntu (bug-fix) packages available from Ubuntu PPA repository IntuitiveNipple 5087 10 Aug 2009 - 00:42
AngelCarpintero
Segfault due to incorrect checking for strerror_r in motion_log (motion.c) MoronicRegistration 4815 10 Aug 2009 - 00:26
AngelCarpintero
motion spams /var/log/messages WikiGuest 4777 10 Aug 2009 - 00:21
AngelCarpintero
motion crashes with 'codec not found' error on debian ('testing') FolkertvanHeusden 5387 12 Apr 2009 - 03:53
DmitriRodik
IS BugReport2006x03x10x000151 really fixed? TeamLoser 5770 02 Mar 2009 - 16:25
AngelCarpintero
Motion dies when running megapixel image GunnarSkjold 5123 22 Sep 2008 - 05:46
AngelCarpintero
Netcam gives "Error reading image header" occasionally SimonW 5232 22 Sep 2008 - 05:46
AngelCarpintero
Deb packages for ubuntu try to run daemon when installing it BradTempleton 5109 20 Sep 2008 - 16:55
AngelCarpintero
configure --with-pgsql=DIR checking postgresql does not return results JunqianXu 5234 20 Sep 2008 - 16:55
AngelCarpintero
Motion Web Bug TWikiGuest 5160 20 Sep 2008 - 16:54
AngelCarpintero
d-link dcs-900 connection lost after a short time TWikiGuest 5262 18 May 2008 - 23:35
AngelCarpintero
mjpegtools breaks compilation in AMD64 AngelCarpintero 5359 18 May 2008 - 23:34
AngelCarpintero
motion won't reconnect to mysql server if it's disconnected A3ricJohanson 5476 18 May 2008 - 23:34
AngelCarpintero
RoundRobin v4l2 buffers in driver when switching input DagErlandsson 5466 18 May 2008 - 23:33
AngelCarpintero
Can't get better pixel resolution IraMoss 5462 18 May 2008 - 23:33
AngelCarpintero
Problem of a motion on architecture x86_64. RafisKhayrullin 5354 18 May 2008 - 23:32
AngelCarpintero
Choose preferable palette bug? OnakraName 5269 18 May 2008 - 23:30
AngelCarpintero
Uninitialized Struct in v4l_set_input JasonSharpee 5325 18 May 2008 - 23:30
AngelCarpintero
httpd control is totally broken now KennethLavrsen 5323 18 May 2008 - 23:29
AngelCarpintero
http control uses invalid html AxelAmthor 5326 18 May 2008 - 23:29
AngelCarpintero
Motion doesn't build with latest ffmpeg Georgi D. Sotirov 5375 18 May 2008 - 23:29
AngelCarpintero
motion can't open motion.conf JohnBray 5234 18 May 2008 - 23:27
AngelCarpintero
3.2.8_beta1 - picture's red and blue colours are swaped. using v4l2 sn9c102 driver JaredD 5499 21 Feb 2008 - 06:38
KennethLavrsen
Segmentation fault at video_common.c:830 DamianWrobel 5565 21 Feb 2008 - 06:37
KennethLavrsen
Bug in ffmpeg_avcodec_log KennethLavrsen 5571 21 Feb 2008 - 06:36
KennethLavrsen
Can't Compile 64 bit KevinMifflin 5643 21 Feb 2008 - 06:35
KennethLavrsen
Captured images become corrupted on FreeBSD (6.2-RC1) TWikiGuest 5683 21 Feb 2008 - 06:33
KennethLavrsen
MySQL does not reconnect if connection is dropped GunnarSkjold 5737 21 Feb 2008 - 06:33
KennethLavrsen
Tracking only X (Pan) with value from Y(Tilt) DirkWesenberg 5580 06 Feb 2008 - 04:49
AngelCarpintero
Motion hangs when quit/restarted through the web control interface. DamonKohler 5333 11 Dec 2007 - 09:19
AngelCarpintero
motion-3.2.8_beta1 compile problems with -DWITHOUT_V4L EvilPete 5536 29 Apr 2007 - 19:54
AngelCarpintero
mySQL not working KevinMifflin 5648 29 Apr 2007 - 18:42
AngelCarpintero
warning, clipping 1 dct coefficients to -127..127 KennethLavrsen 6165 16 Nov 2006 - 17:08
SimonW
superfluous free in ffmpeg.c EvilPete 6007 20 Oct 2006 - 21:46
KennethLavrsen
sql_mask not initialisated correctly AngelCarpintero 6010 20 Oct 2006 - 21:42
KennethLavrsen
Segmentation Fault on Size Changes, when Mask Image doesn't fit AxelAmthor 6103 20 Oct 2006 - 21:42
KennethLavrsen
CPU usage at 99.99% if all network cameras are PAUSED GregSwift 5981 20 Oct 2006 - 21:26
KennethLavrsen
Pan & Tilt broken TWikiGuest 6028 20 Oct 2006 - 21:23
KennethLavrsen
error compiling version 3.2.5.1 (time_last_frame and time_current_frame undeclared) AndreaDelPriore 5952 20 Oct 2006 - 21:20
KennethLavrsen
Netcam reconnects floods syslog KennethLavrsen 5918 20 Oct 2006 - 21:18
KennethLavrsen
Motion won't exit until it has reconnected to all cameras after a successful start JeffGroves 5989 20 Oct 2006 - 21:18
KennethLavrsen
auto brightness "blinks" AndrzejJanuszkiewicz 5981 20 Oct 2006 - 21:15
KennethLavrsen
configure fails testing -pthread on FreeBSD TWikiGuest 5831 20 Oct 2006 - 20:49
KennethLavrsen
configure defines a redundant freebsd for motion on FreeBSD TWikiGuest 5831 20 Oct 2006 - 20:48
KennethLavrsen
Detection on all threads isnt pause when it is paused on thread 0 GunnarSkjold 5829 20 Oct 2006 - 20:47
KennethLavrsen
Random child threads appear to get killed PeterS 5922 20 Oct 2006 - 20:42
KennethLavrsen
Video signal lost - Adding grey image TheOtherBug 5951 20 Oct 2006 - 20:41
KennethLavrsen
Network Camera snapshots every 60 seconds frequently MISSING GregSwift 5981 12 Mar 2006 - 00:23
KennethLavrsen
Segfault with Motion 3.2.4 and Axis 206M PeterS 6031 02 Jan 2006 - 17:34
PeterS
configure issues NevDull 6126 18 Dec 2005 - 10:30
KennethLavrsen
switchfilter option broken - no motion detected at all KennethLavrsen 6106 18 Dec 2005 - 10:30
KennethLavrsen
Motion quits if any netcams falter at startup. BruceDurham 6114 18 Dec 2005 - 10:30
KennethLavrsen
Zombies are back after signal was replaced by sigaction KennethLavrsen 6068 18 Dec 2005 - 10:29
KennethLavrsen
Motion 3.2.3 crashes with Seg Fault at first detection JMB 6049 18 Dec 2005 - 10:26
KennethLavrsen
Zombie processes from onsave and onmpeg scripts BruceDurham 6452 06 Oct 2005 - 15:21
FredericLOIRETTE
motion events written in reverse order (with netcams) PhilipWalden 6189 29 Aug 2005 - 19:30
KennethLavrsen
Autobrightness is unstable TWikiGuest 6157 17 Aug 2005 - 19:10
KennethLavrsen
Text Display detected as motion Dennis DeDonatis 6157 17 Aug 2005 - 14:37
TWikiGuest
NO proxy support for netcams anymore TWikiGuest 6296 13 Aug 2005 - 19:53
KennethLavrsen
Motion crashes with multiple netcams in v3.1.18 and higher BruceDurham 6320 13 Aug 2005 - 19:53
KennethLavrsen
Cannot compile with latest ffmpeg cvs again KennethLavrsen 6167 13 Aug 2005 - 19:52
KennethLavrsen
Duplicate Images Output AndrewHamilton 6167 13 Aug 2005 - 17:34
KennethLavrsen
accept(): Socket operation on non-socket Dennis DeDonatis 6171 02 Aug 2005 - 23:05
KennethLavrsen
Return of BugReport2005x02x11x170019: Error when building RPMs, attempt to mv nonexistent file PaulBeltrani 6189 02 Aug 2005 - 23:04
KennethLavrsen
Pthread deadlock in motion 3.2.1 ChristopheGRENIER 6238 02 Aug 2005 - 23:04
KennethLavrsen
Motion will not run with ffmpeg 0.4.9pre1 CVS build from at least 20050517 and on. KennethLavrsen 6211 11 Jul 2005 - 18:05
KennethLavrsen
Http Header issue in http control RobertH 6262 29 May 2005 - 06:25
KennethLavrsen
Motion 3.2.1 will not compile with --without-v4l KennethLavrsen 6299 27 May 2005 - 04:06
KennethLavrsen
File Descriptor leak ChristopheGRENIER 6305 27 May 2005 - 04:05
KennethLavrsen
gap setting does not include 'post_capture' frames TerryRiggins 6355 27 May 2005 - 04:05
KennethLavrsen
Segment violation Heap corruption in rgb24toyuv420p (video.c) DanielLadd 6296 27 May 2005 - 04:04
KennethLavrsen
Quickcam Express + Motion -> Bad picture Kevin Drapel 6325 27 May 2005 - 04:04
KennethLavrsen
Multible Netcams doesnt work longer EmptySoft 6341 27 May 2005 - 04:03
KennethLavrsen
When setting low_cpu to non zero CPU load increases WillCooke 6270 27 May 2005 - 04:02
KennethLavrsen
auto_brightness function cycles between black and white, causing false triggers GearboxGraeme 6327 27 May 2005 - 04:02
KennethLavrsen
webcam.c RobertoSpadim 6262 27 May 2005 - 04:02
KennethLavrsen
webcam.c still with problem RobertoSpadim 6258 27 May 2005 - 04:01
KennethLavrsen
ffmpeg reports only YUV420 is supported KennethLavrsen 6242 27 May 2005 - 04:00
KennethLavrsen
Unknown content type with lumenera cameras aaron 6258 27 May 2005 - 04:00
KennethLavrsen
Sometimes motion try to free an invalid memory area ChristopheGRENIER 6244 27 May 2005 - 03:59
KennethLavrsen
Motion 3.2.1 memory leaks heavily when restarted through http control KennethLavrsen 6281 27 May 2005 - 03:58
KennethLavrsen
Network error for a single netcam thread causes motion to quit everything. BruceDurham 6351 12 Apr 2005 - 05:26
BruceDurham
Timelapse feature failes with ffmpeg_timelapse = 1 KennethLavrsen 6353 10 Mar 2005 - 00:44
KennethLavrsen
The streaming netcam feature doesn't appear to work with the Panasonic KX-HCM280. BruceDurham 6369 10 Mar 2005 - 00:43
KennethLavrsen
motionhttpcontrol logitech sphere track set problem RedDevil 6324 10 Mar 2005 - 00:41
KennethLavrsen
Netcam code in 3.1.18 is not stable KennethLavrsen 6353 10 Mar 2005 - 00:39
KennethLavrsen
Segmentation fault Peter Holschbach 6374 07 Mar 2005 - 20:33
KennethLavrsen
still get configure: error: cannot compute sizeof (short int),77 SebaT 6347 25 Feb 2005 - 19:43
AngelCarpintero
Illegal instruction Zoltan Zagarics 6354 25 Feb 2005 - 19:42
AngelCarpintero
Add support for destination directory during RPM builds Paul Beltrani 6342 14 Feb 2005 - 05:22
AngelCarpintero
Error when building RPMs, attempt to mv nonexistant file Paul Beltrani 6342 14 Feb 2005 - 04:55
AngelCarpintero
received signal SIGFPE, Arithmetic exception AngelCarpintero 6401 30 Jan 2005 - 13:31
KennethLavrsen
Doesn't read ~/motion.conf but ~/.motion/motion.conf Samuli Kärkkäinen 6379 30 Jan 2005 - 13:31
KennethLavrsen
What does "don't mix with noise_tune" mean SamuliKaerkkaeinen 6379 30 Jan 2005 - 13:30
KennethLavrsen
Crash when using a netcam configuration TWikiGuest 6375 30 Jan 2005 - 13:30
KennethLavrsen
Rotate doesn't work Mark Tranchant 6371 30 Jan 2005 - 13:29
KennethLavrsen
Feature: wrap up mpeg4 file at ^C SamuliKaerkkaeinen 6378 30 Jan 2005 - 13:29
KennethLavrsen
rotate 180 option create segfault JeremyBrun 6413 30 Jan 2005 - 13:29
KennethLavrsen
Receiving application bug warnings from SYSLOG in Redhat AS 3 PeterS 6450 30 Jan 2005 - 13:28
KennethLavrsen
Timelapse rollover at midnight does not always happen KennethLavrsen 6361 30 Jan 2005 - 13:28
KennethLavrsen
memory leak Chris Schleiermacher 6426 20 Dec 2004 - 23:16
KennethLavrsen
Trouble capturing ffmpeg movie 640x480 at 25fps. KalleAndersson 6452 20 Dec 2004 - 23:15
KennethLavrsen
pwc motion tracking problem Jan 6432 20 Dec 2004 - 22:44
KennethLavrsen
Leading spaces of text_left and text_right lost when saving with xmlrpc MikeLees 6452 01 Nov 2004 - 01:20
KennethLavrsen
Number of topics: 123
Topic revision: r1 - 28 Jan 2010, KennethLavrsen
Copyright © 1999-2022 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Please do not email Kenneth for support questions (read why). Use the Support Requests page or join the Mailing List.
This website only use harmless session cookies. See Cookie Policy for details. By using this website you accept the use of these cookies.